Post Reply 
 
Thread Rating:
  • 14 Vote(s) - 3.36 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.4.1.86
Author Message
ClockMan Offline
All Mighty
*******

Posts: 2,883
Joined: Jan 2011
Reputation: 497
Version: 1.4.3.143
Post: #1
1.4.1.86
  • Update for L2OFF - possible fix for gameguard, read bellow.
  • Fix for packet logging (could cause some crash before)
  • Added to scripts:
    GetQuestManager():GetKillMonsterDataSize(),
    GetQuestManager():GetKillMonsterDataByIndex(index).QuestID,
    GetQuestManager():GetKillMonsterDataByIndex(index).KilledMonstersCount,
    GetQuestManager():GetKillMonsterDataByIndex(index).NPC_ID,
    GetQuestManager():GetKillMonsterDataByIndex(index).Type



Instruction for L2OFF NA:
  1. Kill/Remove Windows Service "nProtect ...." (Don't have it ? Good)
  2. Delete "System\GameGuard.des"
  3. Copy "L2.bin" into "L2.exe"
  4. Download dsetup-v2.zip and put it into L2 System. (replace exist one)
  5. Run game by using "L2.exe"
  6. Run L2Tower.exe
  7. Select in loader "use old injection method", "disable change window name" (only if game will crash with exist one, other options are optional)
  8. Press "Inject into process" or "Inject into next active window", wait for injection. Tip should show up with injection info for Tauti.
  9. Login into game account, select char and play... (make sure you inject bot before you select server)

Notes:
  • Yes, you can get banned
  • Bot will detect if you login into L2 OFF NA servers (IP checking)
  • We don't send/receive any GameGuard packets, except Auth one.
  • After game close GameGuard may try to showup hes webpage or send error report (usually fail), but you may want to terminate ggerror.des

[Image: owner.gif]
(This post was last modified: 07-14-2012 08:56 AM by ClockMan.)
07-14-2012 00:50 AM
Visit this user's website Find all posts by this user Quote this message in a reply
amiroooo Offline
Beta Tester

Posts: 1,270
Joined: Sep 2011
Reputation: 412
Version: 1.4.2.142
Post: #2
RE: 1.4.1.86
Somehow i got message "GameGuard Fail! Please Resrart Lineage2" after like 5 minutes of being logged in.
Although if the game is all on bot behaviour you can see the bot still acting normal (using skills/targeting/moving etc) ,excpet me cant do anything beside clicking [ok] which will lead to closing the client.
So most probably its client side problem not server side coz else i believe server would simply kick us.

And regarding
Quote:We don't send/receive any GameGuard packets, except Auth one.
Is there any chance to add option to send blank gameguard answer when server send Guard Query packet? because all gameguard disabling approaches I encountered in past were either emulating or sending blank answers and that might be for reason (maybe skipping answer flags the account as logged as "out game" client), I have been using l2tower on offical with blank gg answer for over 8 months and didn't receive ban or any warning, so I believe its rather safer with blank answer than none.
(This post was last modified: 07-14-2012 01:42 AM by amiroooo.)
07-14-2012 01:20 AM
Find all posts by this user Quote this message in a reply
ClockMan Offline
All Mighty
*******

Posts: 2,883
Joined: Jan 2011
Reputation: 497
Version: 1.4.3.143
Post: #3
RE: 1.4.1.86
//checking....

[Image: owner.gif]
07-14-2012 08:55 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)